httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: ap_select on BSDI 4.x
Date Sat, 29 Apr 2000 23:14:15 GMT
Marc Slemko wrote:
> 
> If someone can't do the second in the near future, then a nice error would
> be good until the first is reality.  But I'm no autoconf expert (and hope
> to never become one), so I can't suggest the easiest way to add such a
> check... I guess just adding a note to the docs would be passable.
> 

At first blush, scanning the output of 'make --version' to see
if it's GNU might be the quickest way. Something like:

    if ${MAKE:-make} --version | grep GNU 
    then
      echo "We need GNU Make"
      exit
    fi

We can clean that up (redirecting error, making sure $(MAKE) exist
-- 
===========================================================================
   Jim Jagielski   [|]   jim@jaguNET.com   [|]   http://www.jaguNET.com/
                "Are you suggesting coconuts migrate??"

Mime
View raw message