httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <>
Subject Re: cvs commit: apache-2.0/src/os/win32/installer/installdll/test
Date Fri, 28 Apr 2000 19:39:31 GMT
Doug MacEachern wrote:
> i've never seen TRUE/FALSE defined to different values, i've just seen it
> blindly #define-d, when it might already be elsewhere, causing ugly
> compiler warnings.

To be honest, I don't think I've seen it defined differently. Well,
I take that back. FALSE is always (0) and most of the time TRUE
is (!FALSE), although I've also seen (1) and (255). I guess the
point was we're saying that if FALSE isn't defined, set it to
(0), and maybe that's not quite anal enough :) We _require_ it
to be (0), so we almost want:

    #undef FALSE
    #undef TRUE
    #define FALSE (0)
    #define TRUE (!FALSE)

But this could break stupid setups that use a magic number for TRUE,
so that's why I thought APR_TRUE/APR_FALSE might be best.

   Jim Jagielski   [|]   [|]
                "Are you suggesting coconuts migrate??"

View raw message