httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Re: cvs commit: apache-2.0/src README.MPM
Date Mon, 06 Mar 2000 16:15:35 GMT
On Mon, 6 Mar 2000, Manoj Kasichainula wrote:

> On Fri, Mar 03, 2000 at 10:56:33PM -0500, Ryan Bloom wrote:
> > -1.  If you are going to use a feature from 1.3.3, then require 1.3.3, if
> > 1.3 works, then don't require a later version.  It may be easy to install,
> > but that's no excuse for making people do the work.  People are busy, and
> > I don't want to waste their time if we don't have to.
> See, the problem here is that we don't know for sure that 1.3 works.
> Some people have had success with it, but that doesn't mean that it
> won't have problems that 1.3.3 doesn't. Does the 1.3->1.3.3 changelog
> list anything that we might need to know?

My concern, is that from what you said last time, it sounded like you
always want to require the latest tools.  This means that when libtool
1.3.4 is released, even though 1.3.3 is working, we require 1.3.4.

> Now, using this standard, we don't know if 1.3.3 works either.  But,
> since many of the rest of us are using it, we can at least reproduce
> problems with it. If we get some screwy bug report, it would be nice
> to say with confidence that a known libtool bug wasn't the cause.

I have checked the Changelog of libtool.  Obviously, there are changes
that we would like, but I didn't see anything that we couldn't live

> Anyway, I'd be happy with just a stern warning if people aren't
> running the latest libtool (and other tools ). Sound good?

I suggest a warning that if things aren't working properly, then the
programmer should update all tools used during the build process.  But, I
don't want to force people to upgrade, just because things _might_ not


Come to the first official Apache Software Foundation
Conference!!!   <http://ApacheCon.Com/>

Ryan Bloom               
406 29th St.
San Francisco, CA 94131

View raw message