httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ras...@apache.org
Subject Re: unable to configure without autoconf
Date Sun, 09 Jan 2000 05:52:28 GMT
> it seems you can't configure the 2.0 tree unless you have autoconf
> installed... because there's no src/lib/apr/configure.

Just about every project out there works like this.  If you are dealing
with the CVS version, you are expected to have a basic set of tools
installed.  autoconf, automake and libtool, for example.  Of course, when
it comes time to roll a public tarball, these scripts are generated and
included in any such tarball.  Putting generated files into CVS is a huge
hassle, especially when the tool that generates these files differs
slightly across platforms or between versions.  You end up with a
neverending stream of commits on these files.

-Rasmus


Mime
View raw message