httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Bloom <...@raleigh.ibm.com>
Subject Re: Two 1.3.10 items
Date Mon, 10 Jan 2000 19:51:47 GMT
On Mon, 10 Jan 2000, Jim Jagielski wrote:

> I was unaware that the current situation is broken. If it is,
> then I agree that we should fix it for this release.

Okay, I have definately seen this problem.  In fact, there are two
different problems with HPUX as far as I can tell.  My current problem is
that I only have access to a flakey HPUX machine, so I am having a hard
time fixing anything.

The first problem, is that if we compile HPUX without SHARED_CORE but
enabling dynamic modules, the compile fails.  This was caused by commit
1.375to Configure.  I personally suggest we back out that change, and
bring Apache 1.3.10 back to the state that 1.3.9 was in.  This was first
documented in commit 1.369 to Configure and the change that is needed is
pretty big.  Unless somebody who knows the Configure script and has access
to a working HPUX machine can get to this soon, I suggest just backing out
the 1.375 change.

The second problem I am having is that I seem to be getting compile errors
when I use ./configure.  I need to add -Ae to the CFLAGS in order to get
HPUX compiling properly.

Now, as I said the only HPUX machine I have access to seems to be a bit
flakey, so I would like somebody else to confirm that these issues are
there in general, and not just on my system.  If these issues aren't
resolved, I am -1 for a release.  I do have a patch for both problems if
they are actual bugs.  :-)

Ryan

_______________________________________________________________________
Ryan Bloom		rbb@raleigh.ibm.com
4205 S Miami Blvd	
RTP, NC 27709		

Come to the first official Apache Software Foundation
Conference!  <http://ApacheCon.Com/>



Mime
View raw message