httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Re: ap_current_time() is not intuitive
Date Mon, 03 Jan 2000 18:52:17 GMT

> Why not rename ap_get_curtime() to something more descriptive of what it
> is actually doing (converting a time value from one representation to another)?
> I don't have a good suggestion because I don't know the preferred short-hand
> way of saying 'seconds since 1/1/1970', which I always just called 'unix time'.

This is actually pretty descriptive of what we are doing.  We are grabbing
the current time from the time object.  The only thing I could recommend
as a different name would be get_unix_time, and I don't like this, because
it makes us sound less portable.


Ryan Bloom               
6209 H Shanda Dr.
Raleigh, NC 27609		Ryan Bloom -- thinker, adventurer, artist,
				     writer, but mostly, friend.

View raw message