httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Laurie <...@algroup.co.uk>
Subject Re: Apache 2.0 brokenness...
Date Sat, 22 Jan 2000 15:43:54 GMT
"Ralf S. Engelschall" wrote:
> 
> In article <3889A5C4.C107E50C@algroup.co.uk> you wrote:
> 
> > If I run a single instance of the threaded version (by setting
> > MaxClients to 1) it works. If I run multiple instances and debug the
> > connection, it works. If I don't, I get connected, but the browser
> > hangs. I'm not sure how to get a handle on debugging this! Any ideas,
> > anyone?
> >
> > Platform is FreeBSD 3.2.
> 
> Does the problem go away if you use -DNO_SERIALIZED_ACCEPT, Ben?

Hmmm, yes it does.

> If
> yes, then it's the mutex deadlock problem I mentioned a few months
> ago, which occurs with all user space threading environments (e.g.
> FreeBSD uthreads) because Apache 2.0 still uses flock/fcntl for the
> inter-process accept mutex which usually does work only in kernel space
> threading environments (e.g. LinuxThreads). If no, then its some new
> problem.

I must've missed that - would you mind explaining again what the problem
is?

Cheers,

Ben.

--
SECURE HOSTING AT THE BUNKER! http://www.thebunker.net/hosting.htm

http://www.apache-ssl.org/ben.html

"My grandfather once told me that there are two kinds of people: those
who work and those who take the credit. He told me to try to be in the
first group; there was less competition there."
     - Indira Gandhi

Mime
View raw message