httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralf S. Engelschall" <...@engelschall.com>
Subject Re: Apache 2.0 brokenness...
Date Sat, 22 Jan 2000 13:18:01 GMT

In article <3889A5C4.C107E50C@algroup.co.uk> you wrote:

> If I run a single instance of the threaded version (by setting
> MaxClients to 1) it works. If I run multiple instances and debug the
> connection, it works. If I don't, I get connected, but the browser
> hangs. I'm not sure how to get a handle on debugging this! Any ideas,
> anyone?
> 
> Platform is FreeBSD 3.2.

Does the problem go away if you use -DNO_SERIALIZED_ACCEPT, Ben? If
yes, then it's the mutex deadlock problem I mentioned a few months
ago, which occurs with all user space threading environments (e.g.
FreeBSD uthreads) because Apache 2.0 still uses flock/fcntl for the
inter-process accept mutex which usually does work only in kernel space
threading environments (e.g. LinuxThreads). If no, then its some new
problem.
                                       Ralf S. Engelschall
                                       rse@engelschall.com
                                       www.engelschall.com

Mime
View raw message