httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony Finch <...@dotat.at>
Subject binary builds currently broken!, was Re: Apache 1.3.8 pre-release tarball available for testing
Date Tue, 10 Aug 1999 14:32:31 GMT
Cliff Skolnick <cliff@steam.com> wrote:
>
>I still see the problem with the httpd.conf created for the binary install.
>Does anyone else see 404's for a fresh server instead of the congradulations
>page?  I see it on two different solaris2.7 machines.  I sent in a patch but
>I noticed no one commented on it so I though I was mistaken.
>
>Can someone else create a binary install and check this out on other
>platforms?

I have duplicated this problem on FreeBSD 3.2-STABLE and Solaris 2.6,
and I think it's rather worse than you thought -- the patch you posted
recently doesn't completely fix the problem :-( As well as the problem
with DocumentRoot in the installed httpd.conf, all the <Directory>
sections aren't specific enough (<Directory "icons"> rather than
<Directory "/usr/local/apache/icons">), and the Aliases are similarly
broken.

The problem is as follows: binary distributions are supposed to be
independent of the ServerRoot that the server was compiled with, so
all the paths that are used are relative. However, http.conf needs
the absolute path to be inserted wherever @@ServerRoot@@ appears, but
when all the configure stuff runs the @@ServerRoot@@ stuff is
stripped.

I think that quite a lot of fiddling with the various scripts is
needed to fix this properly because of various assumptions all over
the place.

Tony.
-- 
f.a.n.finch    dot@dotat.at    fanf@demon.net    e pluribus unix

Mime
View raw message