httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens-Uwe Mager <...@helios.de>
Subject Re: Apache 2000, err Apache 2.0 gets real
Date Sun, 01 Aug 1999 19:45:01 GMT
On Sun, Aug 01, 1999 at 04:17:42PM +0200, Ralf S. Engelschall wrote:

> That's interesting. Does it mean also that some of the libraries which use
> libtool failed for you, too? I mean that you perhaps had problems with
> installing libtool as a stand-alone package, I doubt. Obviously there are a
> few bugs. But you really mean that the ltmain.sh and ltconfig scripts in a
> package's source tree failed for you? I've to admit that I never have seen
> such a failure and I do lots of libtool-based test compiles on all Unix
> flavors I've access to. At least things like a buffer overflow with old
> /bin/sh I consider a problem of those really old platforms and not really a
> failure of libtool.

I would recommend to try the usage of libtool in mod_jserv, this did
not work under AIX (the compiler and linker options where pretty
bugus). I gave up digging into the script as it was so obfusciated I
could not understand what was going on. This event has made me giving
out the advice to avoid libtool like the plague to anyone who did ask.
For my experience libtool only works for platforms where it is easy to
generate shared libraries (like using cc -G), anything that is more
complicated won't work.

-- 
Jens-Uwe Mager

HELIOS Software GmbH
Steinriede 3
30827 Garbsen
Germany

Phone:		+49 5131 709320
FAX:		+49 5131 709325
Internet:	jum@helios.de

Mime
View raw message