httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Re: ap_ vs apr_ revisited.
Date Wed, 19 May 1999 17:34:44 GMT
> I would ask everybody who has an opinion to vote.  This issue has
> implications which effect all Apache developers.  I will tally the votes
> and report them on Monday morning.  This gives everybody plenty of time
> to vote on this issue.

> I would like to see the prefix for apr functions to be:
>     [ ] ap_       [X] apr_        [ ] I don't care.

I think it would be better to have more prefixes ( like
apr_thread_, apr_io_, apr_mutex_)

More information in the function name -> easier to use the 

2 "categories" ( specified in method name ) are better than 1 category.

In C++ and java the class name helps a lot. A flat namespace may be harder
to use.


View raw message