httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <>
Subject Re: apr_ v.s. ap_
Date Tue, 04 May 1999 18:22:59 GMT
Just my two bits... I'd much prefer for apr functions to be preceded by
apr_.  I don't really have time to really follow all the developments, but
I do like playing with Apache when I have time, and I'm very interested in
playing with the APR, and it'd make my life (and I think, other
programmers lives) easier..

tani hosokawa
river styx internet

On Tue, 4 May 1999, Rodent of Unusual Size wrote:

> Ben Hyde wrote:
> > 
> > In what senario would APR introduce a name that collides with the
> > names used by its principle customer and sponser?  That would be
> > bizzare.
> Mm.  And how about someone who wrote a module for Apache,
> found functionality it liked, and assumed they were part of APR
> and portable outside of Apache?  ap_find_token(), say, or
> perhaps ap_escape_html(), or possibly ap_os_canonical_filename()?
> Those would seem to perform httpd-neutral functions (from the
> names, at least), but they're (currently) part of Apache, not
> APR.
> You seem to be concerned about people having to do a
> s/ap_/apr_/g substitution and finding it painful; I'm
> concerned about people being able to tell from looking at
> a function name whether it's Apache-only or usable elsewhere
> from the APR libraries.  Since most of the things going into
> the I/O layering portion of APR have different semantics
> than their 1.3 counterparts, all module ap_* function calls
> will need to be reviewed by module authors anyway.
> *shrug*
> -- 
> #ken    P-)}
> Ken Coar                    <http://Web.Golux.Com/coar/>
> Apache Software Foundation  <>
> "Apache Server for Dummies" <http://Web.Golux.Com/coar/ASFD/>

View raw message