httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raymond S Brand <r...@rsbx.net>
Subject [PATCH] EVIL hack
Date Tue, 27 Apr 1999 12:49:04 GMT
This message contains an EVIL hack. It is a patch that can be applied AFTER
applying my patch to mod_autoindex.

>From my patch to mod_autoindex:
> Quirks:
> 	Some of the environment variables, as displayed by mod_include's #printenv, reflect
> 	the header or readme file, not the directory. See the following "EVIL hack" message.

The following patch fixes the problem. It suffers from the following problems:
	1) mod_autoindex now requires mod_include.
	2) mod_include must be LoadModuled before mod_autoindex
	3) There REALLY needs to be a better way to do this so that
		independent modules do not become dependent on each
		other.

Raymond S Brand
Mime
View raw message