httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manoj Kasichainula <man...@io.com>
Subject Re: cvs commit: apache-apr/apr/lib apr_pools.c Makefile.in
Date Wed, 28 Apr 1999 21:33:46 GMT
On Wed, Apr 28, 1999 at 05:12:06PM -0400, Ben Hyde wrote:
> Maybe it is a little late to say anything but I wish that apr_ was
> just ap_ in apr.  The prefix ap_ exists only to create a safe
> namespace when code written by total strangers join up in the stupid C
> linker.

Now that we're talking about 2.0, maybe it's time to have the
prefix discussion again. *duck*

> The apr_ namespace and the ap_ namespace are not going to
> need to be protected from each other, they are very good friends.  In
> fact amoung friends it seems cruel for Mr. APR to make Mr. AP rewrite
> a mess of code, for a while we will want to keep things in multiple
> CVS branchs in some kind of sync and this makes it harder.

If we decide to keep the apr_ prefix, we could temporarily use a
header file with a bunch of #defines like ap_compat.h. Then when we
get close to a 2.0 release, we can switch to the new naming scheme.

It's much easier to to a search and replace from apr_ to ap_ than to
pick out appropriate ap_ names and rename them to apr_. So if we
decide to stick with ap_ for everything, we should be confident that
we won't change our minds.

-- 
Manoj Kasichainula - manojk at io dot com - http://www.io.com/~manojk/
"People who live in glass houses should get dressed with the lights
out." - Yakko Warner

Mime
View raw message