httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralf S. Engelschall" <...@engelschall.com>
Subject Re: External compiled modules in v1.3.4 / Solasris v2.7
Date Fri, 23 Apr 1999 18:38:08 GMT

In article <371AE0B6.FAF21532@dsn.ericsson.se> you wrote:
> "Ralf S. Engelschall" wrote:
> 
>> > What exactly is the error message trying to tell me?
>> 
>> It clearly tells you that the symbol "auth_ldap_module" cannot be looked up by
>> dlsym() in the module...
> 
> Yep, that's what I thought (but not being clued up at all on DSO I
> figured I should ask).
> 
> A quick grep through the source code indicates the symbol is there. A
> quick search through the binary module that is generated indicates the
> symbol is not there.
> 
> So far I suspect a problem with apxs, where the required symbols are not
> being included in the module during the build process.
> 
> Has apxs been tested with Solaris v2.7?

APXS is just a wrapper around compiler and linker flags and does actually the
same which is done inside the source tree for building DSOs. So I don't think
the problem is somewhere in APXS. The problem seems to be a general DSO/symbol
problem then...
                                       Ralf S. Engelschall
                                       rse@engelschall.com
                                       www.engelschall.com

Mime
View raw message