httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralf S. Engelschall" <...@engelschall.com>
Subject Re: Problem building/installing Apache as non-root.
Date Mon, 19 Apr 1999 17:26:02 GMT

In article <371743CF.EA770E89@raleigh.ibm.com> you wrote:

> I have run into a problem trying to build and install Apache 1.3.7-dev using a
> non-root id. The fixes applied by dirkx on
> April 5 to 1.3/Makefile.tmpl (rev. 1.70) and 1.3/configure (rev. 1.80) have
> caused the code to default to conf_user=nobody
> and conf_group=nobody in the non-user case. This causes the make install to try
> to chown/chgrp the proxy cache dir to
> nobody, which causes the make install to fail. The manual fix is easy, change
> the generated Makefile values, but his is not
> a good long term solution.
> 
> It seems that in the trailing if logic in 1.3/configure:
>                                               if [ ".`id | grep root`" = . ];
> then
>                                                  conf_port="8080"
>                                               fi
> that some code needs to be added inside of here to parse the current user and
> group information from the `id` command.

Thanks for the hint. I'll look into this the next days and try
to fix in a portable way.
                                       Ralf S. Engelschall
                                       rse@engelschall.com
                                       www.engelschall.com

Mime
View raw message