httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Bloom <...@raleigh.ibm.com>
Subject Function and type names.
Date Tue, 23 Feb 1999 17:53:56 GMT

I want to make a decision about APR naming conventions before I get too
deep in implementing functions.  I am therefore making a few suggestions,
so that I don't have to re-name all the types and functions later.

Suggestion 1)
     types:           apr_foo_t
     functions:       apr_bar
     macros & #defs:  APR_STUFF


Suggestion 2)
     types:           apr_foo
     functions:       apr_bar
     macros & #defs:  APR_STUFF

Suggestion 3)
     types:           APRFoo
     functions:       apr_bar
     macros & #defs:  APR_STUFF

Suggestion 4)
     types:           APR_foo
     functions:       apr_bar
     macros & #defs:  APR_STUFF

Personnaly, I vote for #1 or #2.  I really don't care which, but I would
love to get this issue resolved, soon.

Ryan


_______________________________________________________________________
Ryan Bloom		rbb@raleigh.ibm.com
4205 S Miami Blvd	
RTP, NC 27709		It's a beautiful sight to see good dancers 
			doing simple steps.  It's a painful sight to
			see beginners doing complicated patterns.	


Mime
View raw message