httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manoj Kasichainula <man...@io.com>
Subject Re: Function and type names.
Date Thu, 25 Feb 1999 03:19:49 GMT
On Wed, Feb 24, 1999 at 11:05:32PM +0000, Ben Laurie wrote:
> Ryan Bloom wrote:
> > Suggestion 3)
> >      types:           APRFoo
> >      functions:       apr_bar
> >      macros & #defs:  APR_STUFF
> 
> I like this for types, but functions should also be that way (or maybe
> aprBar?). Past experience suggests that my preference is the kiss of
> death :-) (cf. Apache Style Guide).

I was the reason that #3 was originally in the APR spec. I like it
because I like the at-a-glance separation of types and functions.
IMO, it makes code easier to read.

-- 
Manoj Kasichainula - manojk at io dot com - http://www.io.com/~manojk/
"Stocks said 'boo' today..." - Okito Toyoda of NHK on Halloween '96 

Mime
View raw message