httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralf S. Engelschall" <...@engelschall.com>
Subject Re: version info at runtime
Date Fri, 19 Feb 1999 11:59:38 GMT

In article <36CB52A6.5C1E3A2B@lyra.org> you wrote:
> treilly@livesoftware.com wrote:

>> Is there a way for my DSO module to obtain apache's version numbers at
>> runtime?  I'm trying to overcome the highly annoying fact that 1.3.2/3
>> and 1.3.4 modules are incompatible by including two module structs.  I
>> need to have my DSO work with 1.3.4 and 1.3.2/3 version of apache.

> Dunno. One of the Apache developers should be able to answer.

You can either use the low-level MODULE_MAGIC_NUMBER_MAJOR and
MODULE_MAGIC_NUMBER_MINOR defines which can be used for granular matching or
match the version inside the ap_get_server_version() string for high-level
matching. I recommend you to use the MODULE_MAGIC_NUMBER_xx stuff.

                                       Ralf S. Engelschall
                                       rse@engelschall.com
                                       www.engelschall.com

Mime
View raw message