httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralf S. Engelschall" <...@engelschall.com>
Subject Re: don't tell me the path junk is even more screwed up...
Date Thu, 14 Jan 1999 10:17:16 GMT

In article <199901131944.MAA03212@valis.worldgate.com> you wrote:

> on Sparc Solaris 2.5.1 I try to install and get Apache 1.3.4 running:

>    ./configure --prefix=/usr/local/etc/apache_1.3.4
>    make
>    make install
>  
>    /usr/local/etc/apache_1.3.4/bin/apachectl start
>    fopen: No such file or directory
>    httpd: could not open document config file /usr/local/apache/conf/httpd.conf

> Why is Apache looking in  

>     /usr/local/apache/conf 

> for its config file? Should it not look in:

>    /usr/local/etc/apache_1.3.4/conf

> since that is what I specified with the prefix command? The 'apachectl'
> seems to have no way to specify the location of the 

>    /usr/local/apache/conf/httpd.conf

> file. Is there a solution outside of symbolic links?

No, seems like this guy has messed up something locally.  I've tried it with a
fresh extracted 1.3.4 tarball and it worked fine for me.  Additionally
--show-layout also showed the correct layout.

                                       Ralf S. Engelschall
                                       rse@engelschall.com
                                       www.engelschall.com

Mime
View raw message