httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From snyland@workfire.com (snyl...@workfire.com)
Subject Apache 1.3.2 Win32 build - proxy problem on Win98
Date Wed, 23 Sep 1998 01:11:09 GMT
I installed apache_1_3_2_win32_1.exe on Windows 98 just fine.  Then I
did LoadModule for the proxy.  This seemed fine until I had browsed for
a few minutes.

Several (5) times in the last 20 minutes I have been able to make the
proxy crash.  Here's the detailed error printout:

APACHE caused an invalid page fault in
module APACHEMODULEPROXY.DLL at 015f:00867a0e.
Registers:
EAX=00000000 CS=015f EIP=00867a0e EFLGS=00010286
EBX=00000000 SS=0167 ESP=0097bdec EBP=006dcfc8
ECX=00000000 DS=0167 ESI=000012c8 FS=13b7
EDX=006dc398 ES=0167 EDI=ffffffff GS=0000
Bytes at CS:EIP:
8b 48 30 8b 02 51 50 ff 15 18 c3 86 00 8b 4d 0c
Stack dump:
006dcfc8 006d9348 006dc398 ffffffff 00000000 0000583b 006ef49c 0a0d0a0d
2d2d213c 2d2d2d2d 542d2d2d 204d4145 4e49414d 2d2d2d2d 3e2d2d2d 663c0a0d

The error log is empty.  I have not yet run with the debugger as I was
simply testing the Win32 binary.  I haven't even tried to build the
source yet.

I made no changes at all to the config files except to LoadModule the
proxy and then turn ProxyRequests on.  I don't even have the cache
turned on.

On the bright side, everything worked very very well with the default
setup.  I was impressed with how clean the install has become and with
the fact that the default install actually runs with no
intervention/configuration changes at all from the user.  Very excellent
work!

-- Jenn Nyland


Mime
View raw message