httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject STATUS note
Date Mon, 21 Sep 1998 02:21:55 GMT
Apache 1.3 STATUS:

RELEASE SHOWSTOPPERS:

    * DB1.x vs. DB2.x:
      Jim: We need to make sure that db2 is backwards compatible with
           db1 or else make sure that people know to update their DB
	   files (or are we calling db2 files different names?)

      Roy: I don't understand why we should stop everything for this.
           Does the current cvs work with existing db files, or not?
           If not, let's fix it.  If unknown, it isn't a showstopper.

My concern is that previous versions of Apache were not db2 "aware"
best as I can determine. Thus, Apache would use db1 by default with
mod_auth_db.c. Now that Apache "knows" about db2, it looks like it
prefers that over db1, which means that this will break "old" db
databases unless db2 can read db1 files. I simply don't know if
it will, but if it doesn't then this looks like a compatibility
problem.
-- 
===========================================================================
   Jim Jagielski   |||   jim@jaguNET.com   |||   http://www.jaguNET.com/
            "That's no ordinary rabbit... that's the most foul,
            cruel and bad-tempered rodent you ever laid eyes on"

Mime
View raw message