httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralf S. Engelschall" <...@engelschall.com>
Subject Re: apache, aix and error 'not an import library' [FWD]
Date Fri, 18 Sep 1998 17:17:00 GMT

For our AIX experts to chec before 1.3.2. 
That's the DSO problem I asked you last time.

-- forwarded message --
From: Martin Bruemmer <mbruemme@rz.uni-osnabrueck.de>
Newsgroups: comp.infosystems.www.servers.unix
Subject: Re: apache, aix and error 'not an import library'
Date: Fri, 18 Sep 1998 16:06:55 +0200

> Are you sure the gcc that is installed was designed for the exact 
> version of the OS that you are using?

Thank you for answer. GCC 2.7.2 is a binary version compiled with AIX
4.1.  I didn't found a gcc  compiled with an newer Version of AIX. 
Meanwhile I changed from AIX 4.3 to AIX 4.2., Apache 1.3.1 and GNU gcc
2.7.2. are still equal.

The compiling is good, but now, after typing `make` the procedure is
broken by new errors:

	Target "lib" is up to date.
	<=== src/regex
	===> src/os/unix
        gcc -c  -I../../os/unix -I../../include   -DAIX=42 -U__STR__
	-DAIX_BIND_
	PROCESSOR -DUSE_HSREGEX `../../apaci` os.c
	In file included from os.c:20:
-->	os-aix-dso.c:133: conflicting types for `dlerror'
-->	/usr/include/dlfcn.h:35: previous declaration of `dlerror'
	make: 1254-004 The error code from the last command is 1.

	Stop.
	make: 1254-004 The error code from the last command is 1.

	Stop.
	make: 1254-004 The error code from the last command is 2.

	Stop.
	make: 1254-004 The error code from the last command is 2.

	Stop.                                                                  

Can you tell me an other non commercial compiler, or an other way to
compile Apache?

TIA,
Martin
-- end of forwarded message --

                                       Ralf S. Engelschall
                                       rse@engelschall.com
                                       www.engelschall.com

Mime
View raw message