httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doug MacEachern <>
Subject Re: 2 more API thingies
Date Wed, 05 Aug 1998 14:41:14 GMT
At 08:13 AM 8/5/98 +0200, Ralf S. Engelschall wrote:
>In article <> you wrote:
>> Shouldn't the is_HTTP_*() macros have the ap_ prefix?
>They should, because they are used also inside modules and
>not only the core code:
>Feel free to rename them to ap_is_xxxx!

Don't you have a script to do this already?  Seems like a simple enough
task, just rename in the source files and add to ap_compat.h, right?

>> Can we API_EXPORT scan_script_header_err_core()?
>> At the moment, I have some 1.2.x copy-n-pasted code to scan headers from a
>> string in mod_perl, that could be rid of if we could see
>> scan_script_header_err_core().
>Sounds reasonable to me, too. But only if at the same time you rename it to
>ap_xxx, of course. Just adding API_EXPORT is not ok.



View raw message