httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Jacobowitz <d...@false.org>
Subject Re: DSO support in Rhapsody, mapped files, and other fun
Date Thu, 06 Aug 1998 00:22:32 GMT
On Wed, Aug 05, 1998 at 11:03:54AM -0700, Dean Gaudet wrote:
> 
> On Wed, 5 Aug 1998, Wilfredo Sanchez wrote:
> 
> The double configuration is a feature.  Pretty much everyone stumbles into
> it at some point.  (That, and discovering that -X respects
> MaxRequestsPerChild are usually head scratchers ;) 

Awww, and I thought I was special :)


Which brings me back to the mod_perl oddities (again).

The problem, as far as I can tell, is with the initialization.  I can't
tell for certain whether or not this happening, but shouldn't a
module's init_module() function be called when it is loaded, instead of
only before the second config file re-reading?

Also, and this one has me totally puzzled, the first time mod_perl gets
loaded it looks at the symbol perl_running.  It finds a 1 there.  This
is bizarre because the only function that changes this variable has
definitely not yet been called.  Then, the second time it is loaded (is
the module actually unloaded and reloaded?) the symbol is correctly 0.

Any idea where this could be coming from?  I haven't checked for this
specific issue but I'm told that it works with no other modules loaded;
I'll retry that soon and see if perl_running is correct in that case.

Dan

Mime
View raw message