httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James H. Cloos Jr." <cl...@jhcloos.com>
Subject Odd lossage
Date Tue, 28 Jul 1998 20:59:08 GMT
I was just trying to get php3 (from CVS) compiled in to the latest 1.3
CVS, and got hit by this unusual error.

I think this diff is most illustrative:

====================cut====================

--- modperl/apache-1.3/src/include/ap_config_auto.h     Tue Jul 28 13:41:48 1998
+++ php3/apache-1.3/src/include/ap_config_auto.h        Tue Jul 28 14:57:37 1998
@@ -7,8 +7,8 @@
 #define AP_CONFIG_AUTO_H
 
 /* check: #include <dlfcn.h> */
-#ifndef HAVE_DLFCN_H
-#define HAVE_DLFCN_H 1
+#ifdef HAVE_DLFCN_H
+#undef HAVE_DLFCN_H
 #endif
 
 /* check: #include <dl.h> */
@@ -22,23 +22,23 @@
 #endif
 
 /* check: #include <crypt.h> */
-#ifndef HAVE_CRYPT_H
-#define HAVE_CRYPT_H 1
+#ifdef HAVE_CRYPT_H
+#undef HAVE_CRYPT_H
 #endif
 
 /* check: #include <unistd.h> */
-#ifndef HAVE_UNISTD_H
-#define HAVE_UNISTD_H 1
+#ifdef HAVE_UNISTD_H
+#undef HAVE_UNISTD_H
 #endif
 
 /* check: #include <sys/resource.h> */
-#ifndef HAVE_SYS_RESOURCE_H
-#define HAVE_SYS_RESOURCE_H 1
+#ifdef HAVE_SYS_RESOURCE_H
+#undef HAVE_SYS_RESOURCE_H
 #endif
 
 /* check: #include <sys/select.h> */
-#ifndef HAVE_SYS_SELECT_H
-#define HAVE_SYS_SELECT_H 1
+#ifdef HAVE_SYS_SELECT_H
+#undef HAVE_SYS_SELECT_H
 #endif
 
 /* check: #include <sys/processor.h> */
@@ -56,29 +56,19 @@
 #define STATUS 
 #endif
 
-/* build flag: -DMOD_PERL */
-#ifndef MOD_PERL
-#define MOD_PERL 
-#endif
-
-/* build flag: -DUSE_PERL_SSI */
-#ifndef USE_PERL_SSI
-#define USE_PERL_SSI 
-#endif
-
-/* build flag: -Dbool=char */
-#ifndef bool
-#define bool char
-#endif
-
-/* build flag: -DHAS_BOOL */
-#ifndef HAS_BOOL
-#define HAS_BOOL 
+/* build flag: -DNO_DBM_REWRITEMAP */
+#ifndef NO_DBM_REWRITEMAP
+#define NO_DBM_REWRITEMAP 
 #endif
 
 /* build flag: -DUSE_HSREGEX */
 #ifndef USE_HSREGEX
 #define USE_HSREGEX 
+#endif
+
+/* build flag: -DSERVER_SUBVERSION="PHP/3.0.3-dev" */
+#ifndef SERVER_SUBVERSION
+#define SERVER_SUBVERSION "PHP/3.0.3-dev"
 #endif
 
 #endif /* AP_CONFIG_AUTO_H */
====================cut====================

The first directory was used for a test of 1.3 + modperl, the latter
for the failed test of 1.3 plus php3.  The lack of HAVE_UNISTD_H
caused alloc.c to fail to compile, since STDIN_FILENO et al were note
defined.

The cause of the lossage you ask?

I'd configured a number of php3's extra bits, including the IMAP
module.  Needing UW imapd's c-client.a, and having a full mirror of
redhat-5.1 on this box, I installed imap-4.1.final-1.src.rpm from the
updates and `rpm -bc'ed it, manually installing the library and 3
needed headers in /usr/local.

And here is the stickler: since rpm added in RedHat's patches, the
resultant c-client.a is dependent on libpam.  Added env LIBS=-lpam to
the ./configure causes the lossage.  Seems linking against it breaks
the tests in TestCompile.

Now, I'm not too sure what possible reason the client lib would have
to reference libpam (the server sure; but the client?!) so I'll just
recompile libc-client.a.  An easy workaround^Wfix.

Just a heads up, in case anyone else runs into this.

-JimC
-- 
James H. Cloos, Jr. 
<cloos@jhcloos.com> 
PGP KeyId=0xB84D7D6F <http://www.jhcloos.com/cloos/pgp_public_key.txt>
    Fingerprint20 = F265 CF1F 1951 A103 E287  1350 1A0D 598D B84D 7D6F


Mime
View raw message