httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Southwell <da...@cyberc.demon.co.uk>
Subject Re: mod_proxy and win32
Date Fri, 24 Jul 1998 17:03:11 GMT
On Fri, 24 Jul 1998, snyland@workfire.com wrote:

> David Southwell wrote:

> > Are you referring to a Release or a Debug  compile?
> 
> Debug.  I have not tried building a Release version.

> 
> What?!?  Are you saying that you're getting errors  _compiling_   the debug
> version of mod_proxy 1.3.1?  I have not seen compile errors for this on Win95
> A, B, or C or on NT 4.0.

release I have running OK on windows 98
(I presume yr NT4 has Service Pack 3!)
Is that workstation or server or both?


Sorry for mod_proxy I did not get compile errors
I do get compile errors for mod_info (release and debug) but I think
that is a config problem tho! :0

I cannot get apachecore to run in debug mode on NT but it maybe due to
code modifications to apache not compatible with some of our code.. I dont
know yet..

> 
> (I did have to change a few things in a couple of projects, like putting
> ApacheCore.dll in the same directory as Apache.exe, which implies that
> ApacheCore.lib is also in that directory, so you have to point some other
> projects to ApacheCore.lib in its new directory.  Also had to build a couple
> of projects that aren't mentioned in the instructions for building on Win32,
> but it does work.)

Umph I havent had time yet to do any detailed tracing

> > 1.3.0 and 1.3.1 debug versions of ApacheCore compile on NT 64M 200Mhz
> > system but will not run :-(.

> Uh Oh.  Could you be more specific when you say, "will not run"? What exactly
> are you seeing?  I will go back to my NT 4.0 SP3 machine today just to check

I cannot remeber now but I will re-run it and give you the error output -
I compiled it on my development machine but installed it over the network
onto machibne and subsequently reallised that the instal machine did not
have VC++ by which time I was onto something else !!! 
Shot myself in the foot there!!


> again that we have the new 1.3.1 release running.  I can't remember checking
> that since we ran 1.3.0.

> > R versions compiled (using VC++.) run fine. I havent tried other compilers
> > yet.

> We're using Visual C++ 5.0.  Debug versions compiled & run ok.
Yep ours is VC++ 5.0 also strange 

> > I am just about to have a go with 1.3.2

> > One exception is ApacheInfo which (as yet) I cannot get to compile
> > satisfactorily - the problem is with linking ap_* - hope to track this
> > down.
> >
> > All compile fine on NetBSD/Linux using gcc
> >
> > I haven`t yet tried AIX/Sun yet
I now have FreeBSD running fine - for what its worth!!



David Southwell
Chairman      
CyberCity Ltd            (European agents for CyberCity Inc. BVI)
+44 117 955 8225            CyberCity Technology in Europe
BCDP Technology ++Beyond the Corporate Doorway Processing Solutions++


Mime
View raw message