httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From snyland@workfire.com (snyl...@workfire.com)
Subject Re: [BUG] Win32 assert: sub_canonical_filename() called with szFile==""
Date Thu, 16 Jul 1998 17:02:29 GMT


Marc Slemko wrote:

> On Thu, 16 Jul 1998, snyland@workfire.com wrote:
>
> > Um,  _please_  take another look at ap_os_canonical_filename where the code blows
> > away trailing slashes.  As of the last cvs snapshot I have today (19980716130028),
it
> > builds but still dies at runtime when it sees <Directory /> in the default
>
> Yes, that is what I said.
>
> The workaround I plan for the release is just to remove that from the
> default config file for now.
>

Oh.  Ok.  I noticed it hadn't been changed in that snapshot.  You know better than I if
that is a reasonable workaround that won't mess up people who plan to actually use your
server in the field (so to speak).  Seems a pretty big stretch not to allow anyone to have
a <Directory /> section in any of their conf files.  Whatever.  Let me know if I can
help.
I feel like I am just criticizing here. My apologies.

BTW, does _anyone_ use the current-testers mailing list?  I signed up, but I never get
anything from it.  That's probably a more appropriate forum for me since I have not been
contributing solutions.

> > access.conf.  If you release it this will make a lot of Win32 guys very unhappy,
even
> > if you do document it.  Isn't there anything that can be done about this for 1.3.1?
> > Basically it doesn't run out of the box.  :-(
> >
> >


Mime
View raw message