httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harrie Hazewinkel <harrie.hazewin...@jrc.it>
Subject the use of ./configure
Date Tue, 02 Jun 1998 09:47:19 GMT
HI all,


I have found some problems with the use of './configure'
during the installation process. I discovered 

Correct me if I am wrong, but it is my understanding that
the 'configuration'-file src/Configuration is used to 
determine the configuration and that is setup by
'./configure'.

Thew problem:
If I add an EXTRA_CFLAG in 'src/Configuration', like
'-ggdb', it does not show up in the Makefiles.
What happens is that the line of the 'EXTRA_CFLAGS' is

EXTRA_CFLAGS=`$(SRCDIR)/apaci`

and should be 

EXTRA_CFLAGS=-ggdb `$(SRCDIR)/apaci`

The same is for the EXTRA_INCLUDES and the EXTRA_LIBS
of the 'src/Configuration' when I would like to have
for instance, 'EXTRA_INCLUDES=-I/usr/local/include'
and 'EXTRA_LIBS=-L/usr/local/lib -lgdbm'.
These lines stay empty.

If I repeat this for the 'src/Configuration.tmpl' I 
get the following results

EXTRA_CFLAGS does not show up in the Makefiles.
EXTRA_INCLUDES shows up in the Makefile
EXTRA_LIBS shows up in the Makefile


It seems to me that the './configure' script takes its
input from 'src/Configuration.tmpl' instaed of
'src/Configuration' and the EXTRA_CFLAGS are not 
included at all in the Makefiles.


I tested this with the 1.3.0 on a SUN ultra 5 with
Solaris 2.6 and the 1.3b7 on a FreeBSD 3.0 .

-- 
HA HA
0- Harrie Hazewinkel --------------------------------------0
 mailto:harrie.hazewinkel@jrc.it       phone:+39+332+786322
 http://sikorsky.sai.jrc.it/~harrie/     fax:+39+332+785641
 postal: JRC of the E.C.  -  CEO  -  Ispra 21020 (VA) Italy
0----------------------------------------------------------0
  Ik ben Harrie en ik ben 28 jaar en doe SNMP na. MIB, MIB

Mime
View raw message