httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralf S. Engelschall" <...@engelschall.com>
Subject Re: FW: Help with Installation on Solaris 2.6
Date Sat, 13 Jun 1998 11:51:33 GMT

>            I am trying to install the apache httpd server on a sol2.6 
> platform and am having difficulties. I wanted to include the mod_perl
> module so as your README.configure says I first built mod_perl and then
> ran configure and make in the apache-1.3.0 directory. I am getting errors
> at the last stage of compilation - The errors are linking errors - when 
> the compilation tries to build the httpd executable it complains that symbols
> from libperl.a and Constants.o and some others cannot be resolved. I've
> tried various things over the past two days to no avail. Here is a brief
> transcript of my actions:

> 1. I untared mod_perl-1.11.tar and apache_1.3.0-sparc-sun-solaris-26.tar
> 2. I cd to mod_perl-1.11 and did the following:
>     > perl Makefile.PL APACHE_SRC=../apache_1.3.0/src DO_HTTPD=1
>     > make
>     > make install
>     I even did a make test and all tests were successful
> 3. I cd to apache-1.3.0 and confirmed that the file src/modules/perl/libperl.a
>    exists and did the following:
>    > ./configure --activate-module=src/modules/perl/libperl.a 
>    > make
>    And here I get to the point where gcc tries to build httpd and fails due
>    to unresolved symbols used in libperl.a and such

The problem is that the hints in README.configure are for a mod_perl version
which is a little bit newer than 1.11 but still unreleased.  Sorry for this
but mod_perl 1.12 took a little bit more time than expected. With 1.12 this
should work fine. With 1.11 just follow the standard procedure described in
mod_perl's INSTALL file.
                                       Ralf S. Engelschall
                                       rse@engelschall.com
                                       www.engelschall.com

Mime
View raw message