httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dirk-Willem van Gulik <dirk.vangu...@jrc.it>
Subject Re: Desparate for Apache/Linux setup answers
Date Thu, 30 Apr 1998 09:20:45 GMT

Hmm, I recently got a greek rip-off CD which looked like a hacked
slackware with some greek i18n/l9n done to it; which had lf+cr combo's all
over the config files.

Might be the same here. Perhaps checking the file with 'od' or 'hexdump'
would work to see if there are any such things in the file. Or perhaps a
tr -d r < in > out would do the trick.

Dw

On Wed, 29 Apr 1998, Marc Slemko wrote:

> 
> >Newsgroups: comp.infosystems.www.servers.unix
> >Path: scanner.worldgate.com!news.maxwell.syr.edu!news.idt.net!ix.netcom.com!judlew
> >From: judlew@netcom.com (Judith Lewis)
> >Subject: Desparate for Apache/Linux setup answers
> >Message-ID: <judlewEs6pCz.9ww@netcom.com>
> >Keywords: httpd, apache, linux
> >Organization: Netcom On-Line Services
> >X-Newsreader: TIN [version 1.2 PL2]
> >Date: Wed, 29 Apr 1998 16:48:35 GMT
> >Lines: 47
> >Sender: judlew@netcom15.netcom.com
> >Xref: scanner.worldgate.com comp.infosystems.www.servers.unix:42087     
> 
> The answer's got to be obvious, but I cannot figure it out to save my life:
> 
> When I compiled and install Apache 1.3b6, everything goes fine until 
> "apachectl start," which returns this:
> 
> --------
> Syntax error on line 4 of /usr/local/apache/etc/httpd.conf:
> Invalid command '
> ', perhaps mis-spelled or defined by a module not included in the server 
> configuration
> /usr/local/apache/sbin/apachectl start: httpd could not be started
> -------
> 
> It does not matter if the file has not been edited at all, has been 
> opened in vi, elvis, joe or emacs. It always turns out the same. If I 
> comment out the blank lines, it calls typical directives such as 
> "SeverType" and "User" "Invalid Commands."
> 
> I have subsequently tried versions 1.2.6 and 1.2.4, and even the 
> precompiled binary for linux-whatever. The first two return a "syntax 
> error" on every command. At least they don't object to blank lines. The 
> precompiled binary returns "httpd: file not found," or, if I specificy a 
> different httpd.conf with -f, "fopen: file not found." Which indicates to 
> me that a necessarily file is missing from my system that Apache wants,
> but I DON'T KNOW WHAT IT IS! Sorry for yelling. I'm frustrated. I can't 
> be this stupid.
> 
> I have even considered re-building my kernel hoping that would make a 
> difference. But if I did it and it didn't work I'd probably lose my mind.
> 
> Oh, and by the way, I have tried compiling with "HAVE_SHMGET" commented 
> out in conf.h, but that makes no difference either. Anyway, I know I have 
> SysV IPC in my kernel.
> 
> Can anybody help me? Please?!
> 
> Thanks.
> 
> Judith Lewis
> judlew@netcom.com
> 
> 
> 
> 
> 
> -- 
>                                              judlew@netcom.com
> 


Mime
View raw message