httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Slemko <>
Subject Re: cvs commit: apache-1.3/src/test/rename apapi.h
Date Tue, 07 Apr 1998 16:49:09 GMT
On Tue, 7 Apr 1998, Paul Sutton wrote:

> On Tue, 7 Apr 1998, Jim Jagielski wrote:
> > Roy T. Fielding wrote:
> > > I strongly recommend you actually run Ralf's script (on a separate copy
> > > of your repository) and then compare http_main.c.bak versus http_main.c.
> > > There is a world of difference between the individual prefix options.
> > 
> > Done.... and it doesn't change my opinion. I think it would be
> > VERY beneficial to have API functions have their own unique
> > prefix. Instead, we're just going to lump everything into
> > one prefix which sure protects againsts namespace collisions, but
> > does nothing to characterize the functions themselves...
> But surely name space collision is the only thing we are worried about. 
> The HIDE stuff makes Apache work with third party libraries without
> collisions. It is vetoed, so we need a new way to hide symbols. That can
> be done by renaming everything to start ap_. That seems fine to me. It
> will rename some internal stuff. Well, ok, that does not matter because by
> definition it is internal. Module authors should not be using it, and if
> they are the rename will show them they are using something they shouldn't
> and get the to use something else, or track new-httpd more closely if they
> need to use it.

One of the arguments for actually renaming all the functions is to give
Apache a "real" API.  To do that, simply renaming everything to ap_
without thinking about the consequences is the wrong solution.

If it is claimed that the only point to renaming the symbols is to avoid
collisions, then I really do not see that it is appropriate to do so at
this time and I would suggest that the change involved is _FAR_ more than
the significance of the problem warrants.  I have not seen anyone present
any solid arguments for why HIDE is so horrible, while there is agreement
over the long term that a fixed namespace is good, there is no agreement
about how it should be done or what should be a part, etc.

Do we really want to try to force that agreement in 1.3 when we will have
to do the exact damn thing again for 2.0?

View raw message