httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Slemko <>
Subject Re: HIDE summary
Date Wed, 01 Apr 1998 15:01:44 GMT
Good summary, however...

On Wed, 1 Apr 1998, Paul Sutton wrote:

> So, for a future release where we rename symbols to avoid conflicts (e.g. 
> 1.3.0 to 1.3.1): 

Making this sort of API change in a point release (ie. 1.3.0 to 1.3.1)
doesn't make any sense to me and isn't where I think we should be going.

> For 1.3.* we can continue to supply a hide.h which maps to the correct
> exported function. In 1.3.0 this will map palloc() -> AP_palloc(). In
> 1.3.1 it will map palloc() -> ap_palloc(). For 1.3.0 we document to module
> authors that they must not use AP_* names -- they are transitionary names.
> >From 1.3.1 onwards we can document the correct names, such as ap_palloc().
> This provides a clean development path with minimum distruptions to module
> authors after they've upgraded their modules to work with 1.3.0.
> The _only_ alternate to HIDE=yes for 1.3 is that we quickly decide on the
> final API names for all public functions, and make hide.h or the source
> code itself use the correct final names. These eliminates the
> transitionary use of AP_* names, at lets module authors start using the
> final names for their 1.3.0 modules straight away. 

Note that "final names" are only "final 1.3.x names" since things could
well be quite different for 2.0.

View raw message