httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bh...@gensym.com (Ben Hyde)
Subject [PATCH] HPUX10 yearns for SELECT_NEEDS_CAST (take 2)
Date Wed, 15 Apr 1998 11:02:44 GMT
Mark reports this isn't a problem on 10.20, so in this version of the
patch I limit the fix to 10.01 where I'm sure it happens.

Resolve 6 warnings on HPUX10 version 10.01, e.g.:
 http_main.c:1210: warning: passing arg 2 of `select' from incompatible pointer type
 http_main.c:1210: warning: passing arg 4 of `select' from incompatible pointer type

This should be the last of the unix compile warnings.

  - ben hyde

"55 Million individuals over 12 in the US used the Internet in Jan 1998.
That is 26% of that population." from RelevantKnowledge

---
> cvs diff -u Configure
Index: Configure
===================================================================
RCS file: /cvs/apache-1.3/src/Configure,v
retrieving revision 1.237
diff -u -r1.237 Configure
--- Configure	1998/04/12 15:49:26	1.237
+++ Configure	1998/04/15 14:54:48
@@ -341,6 +341,13 @@
     *-hp-hpux10.*)
 	OS='HP-UX 10'
 	CFLAGS="$CFLAGS -DHPUX10"
+ 	case "$PLAT" in
+ 	  *-hp-hpux10.01)
+	       # We know this is a problem in 10.01.
+               # Not a problem in 10.20.  Otherwise, who knows?
+               CFLAGS="$CFLAGS -DSELECT_NEEDS_CAST"
+               ;;	     
+ 	esac
 	DEF_WANTHSREGEX=yes
 	;;
     *-hp-hpux*)

Mime
View raw message