httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bh...@gensym.com (Ben Hyde)
Subject Re: [PATCH] HPUX10 yearns for SELECT_NEEDS_CAST
Date Fri, 10 Apr 1998 19:20:29 GMT

Marc Slemko writes:
> The problem is that more recent versions of HPUX 10.x do not need it
> enabled.  It is just a few early versions that do.  I am sure 10.20
> doesn't, but have never figured the exact dividing line.

This hearsay suggested to me the problem is in HP10.02

  http://search.dejanews.com/getdoc.xp?AN=242988684&fmt=raw
   ...
   ... on an HPUX 10.20  ...
   ... nnect.c:228: warning: passing arg 2 of `select' from incompatible pointer type
   ...
  
But I'm spliting hairs, is special case in Configure 
a better approach?

    *-hp-hpux10.0[01])
	OS='HP-UX 10'
	CFLAGS="$CFLAGS -DHPUX10 -DSELECT_NEEDS_CAST"
	DEF_WANTHSREGEX=yes
	;;

 - ben hyde
"Ask forgiveness not permission."

Mime
View raw message