httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <>
Subject Re: Compromise
Date Wed, 08 Apr 1998 12:58:50 GMT
Ralf S. Engelschall wrote:
> In article <> you wrote:
> > Ralf S. Engelschall wrote:
> >> 
> >> Ok, there is no loss of functionality when we at least provide the
> >> apapi_compat.h header, of course. Ok, I can live with this, too.  Then let us
> >> first rename anything to ap_ (to make HIDE obsolete) and remove HIDE as the
> >> consequence. Then let us push out 1.3b6 and _THEN_ we can again try to debate
> >> about more meaningful prefixes. I think this should be an acceptable way even
> >> for Ken and Jim, isn't it? Because the rename-scripts can be used later again
> >> to move some ap_xxx to <whatever>...
> > If we could, before 1.3b6, do the little renaming and moving required
> > for some already hidden functions (the one's already ap_ which ARE API
> > compared with the ap_'s that aren't, and the 2 apapi_ ones) then I
> > would +1 that in a heartbeat.
> I know what point you want to address, Jim, but sorry, my english is a little
> bit too bad to understand what exactly should be renamed to what. Do you mean
> we should first rename existing ap_xxx functions to xxx or to apapi_xxx? BTW,
> independend how you want it, it can be done in, too. Or do you
> explicitly want to change them in the source manually before?

Forget it... just slap ap_ in front of everything.

   Jim Jagielski   |||   |||
            "That's no ordinary rabbit... that's the most foul,
            cruel and bad-tempered rodent you ever laid eyes on"

View raw message