httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <>
Subject Re: cvs commit: apache-1.3 STATUS
Date Tue, 07 Apr 1998 20:48:27 GMT
Dean Gaudet wrote:
> On Tue, 7 Apr 1998, Jim Jagielski wrote:
> > no difference what we name it... I just can't see how the additional
> > of maybe one single letter to a prefix, which then obviously and
> > clearly defines at the source code level the API, is NOT a good
> > idea.
> Read my comments in the STATUS.  You're leading us down a path where in
> the future we have to rename apapi_palloc to ap_palloc and go through all
> this crap again.

If palloc() is an API function then yes, it would be renamed
<APIPREFIX>_palloc. AFAIK, the "stuff" in libap was never intended to
be API functions, just "cool" functions that Apache uses. If they DO
become API functions then, yep, they'd be renamed and re"tagged" and
the magic-number bumped. What "crap", exactly, would we go through?
And if something is moved OUT of the API, it undergoes a namechange
as well. Where, exactly, is this confusing?

   Jim Jagielski   |||   |||
            "That's no ordinary rabbit... that's the most foul,
            cruel and bad-tempered rodent you ever laid eyes on"

View raw message