httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Gaudet <dgau...@arctic.org>
Subject Re: vetoing hide.h
Date Wed, 01 Apr 1998 02:34:59 GMT


> On Tue, 31 Mar 1998, Roy T. Fielding wrote:
> 
> > Fine. That was not
> >       my concern either. What matters to me is readability, debugging,
> >       and the amount of effort necessary to find a friggin clue in the
> >       source code.  So take UpdateHide and turn it into a global replace
> >       (very carefully, of course) -- run it once.  For backwards
> >       compatibility, create a header file
> > 
> >           old_apache_api.h
> > 
> >       which takes as "input" a new symbol EXPECTED_APACHE_API containing
> >       the module author's magic number, and then remaps symbol names from
> >       the old to the new names.  We can do this, it is no more effort than
> >       HIDE, and it provides a rational path for future changes.
> >       The only problem is we need to decide on the prefix first.

Sorry I should have made clear that I agree to this proposal without the
EXPECTED_APACHE_API part.  I think that part results in a promise of
forward compatibility that we just can't keep.

Dean


Mime
View raw message