httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rodent of Unusual Size <Ken.C...@Golux.Com>
Subject Re: cvs commit: apache-1.3/src/include hide.h
Date Thu, 05 Mar 1998 13:03:42 GMT
Ralf S. Engelschall wrote:
> Unless the _real_ API functions are defined in a list somewhere _and_ renamed
> to a common prefix (apapi) even not hiding them doesn't solve the namespace
> problem in general.

Indeed.  As I mentioned, this can either be done tediously by renaming
the public interfaces to "apapi_mumble" (we seem to have sufficient votes
for that prefix to be considered It), or by identifying them separately
(as you say) in a list in UpdateHide.  The latter option will be faster
but (IMO) less correct.

{Sigh}  When I have some time, I'll see if I can come up with a list
of definitely public interfaces to be prefixed (one way or another)
with "apapi_".  Then I'll make the changes to UpdateHide.  I think we
need to do it this way for 1.3.*, because otherwise module writers
will need to do a significant retrofit - which we shouldn't force
on them until 2.0.

Any objections?  I expect to have a *lot* more time when my new home
desktop arrives next week..  I just can't code conveniently on this

#ken	P-)}

Ken Coar                    <http://Web.Golux.Com/coar/>
Apache Group member         <>
"Apache Server for Dummies" <http://WWW.Dummies.Com/

View raw message