httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rodent of Unusual Size <Ken.C...@Golux.Com>
Subject Re: cvs commit: apache-1.3/src/include hide.h
Date Wed, 04 Mar 1998 13:32:36 GMT
I'll actually go further: I'd like to see the "AP_" prefix
changed to "appriv_" (or whatever we decide the httpd-internal
prefix should be).  If UpdateHide were eventually augmented
to pick up a list of formal API names from somewhere, and
prefixed them with the "apapi_" prefix, I would be very happy -
we'd be well on our way out of this morass of "just what
is the API, anyway?"  We'd have three categories of names:
apapi_xxx for httpd API routines, appriv_xxx for internal httpd
routines, and ap_xxx for Apache reusable routines that aren't
tied to the HTTP project.  Going back and actually renaming
the routines could be done at leisure.

I consider this an extreme goodness.

#ken	P-)}

Ken Coar                    <http://Web.Golux.Com/coar/>
Apache Group member         <>
"Apache Server for Dummies" <http://WWW.Dummies.Com/

View raw message