httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From (Ralf S. Engelschall)
Subject Re: cvs commit: apache-1.3/src/include hide.h
Date Thu, 05 Mar 1998 15:11:35 GMT

In article <34FEA2AE.5CF8DD30@Golux.Com> you wrote:
> Ralf S. Engelschall wrote:

>> Unless the _real_ API functions are defined in a list somewhere _and_ renamed
>> to a common prefix (apapi) even not hiding them doesn't solve the namespace
>> problem in general.

> Indeed.  As I mentioned, this can either be done tediously by renaming
> the public interfaces to "apapi_mumble" (we seem to have sufficient votes
> for that prefix to be considered It), or by identifying them separately
> (as you say) in a list in UpdateHide.  The latter option will be faster
> but (IMO) less correct.

> {Sigh}  When I have some time, I'll see if I can come up with a list
> of definitely public interfaces to be prefixed (one way or another)
> with "apapi_".  Then I'll make the changes to UpdateHide.  I think we
> need to do it this way for 1.3.*, because otherwise module writers
> will need to do a significant retrofit - which we shouldn't force
> on them until 2.0.

Yeah, making this list is a great step further.
Please start it, Ken. We'll need it anyway, either for
UpdateHide or to actually rename the symbols in our sources.
So, please make a first try, Ken. Thanks.

                                       Ralf S. Engelschall

View raw message