httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From (Ralf S. Engelschall)
Subject Re: cvs commit: apache-1.3/src/include hide.h
Date Wed, 04 Mar 1998 13:44:10 GMT

In article <34FD57F4.812DAA58@Golux.Com> you wrote:

> I'll actually go further: I'd like to see the "AP_" prefix
> changed to "appriv_" (or whatever we decide the httpd-internal
> prefix should be).  If UpdateHide were eventually augmented
> to pick up a list of formal API names from somewhere, and
> prefixed them with the "apapi_" prefix, I would be very happy -
> we'd be well on our way out of this morass of "just what
> is the API, anyway?"  We'd have three categories of names:
> apapi_xxx for httpd API routines, appriv_xxx for internal httpd
> routines, and ap_xxx for Apache reusable routines that aren't
> tied to the HTTP project.  Going back and actually renaming
> the routines could be done at leisure.

> I consider this an extreme goodness.

Yes, sounds nice. Even we are doing it at the wrong location, I think.  But to
make this we need a decision scheme for the prefixing.  We can do it this way:
Have a list of apapi-functions and all functions which are not in this list
gets appriv as there prefix.

Hmmmm... seems like the HIDE-feature becomes a general symbol changing
feature, which IMHO is not for what it was intended and written... But +0.

                                       Ralf S. Engelschall

View raw message