httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r..@engelschall.com (Ralf S. Engelschall)
Subject Re: Apache 1.2.5 \& Solaris 2.6 Problems..\?
Date Fri, 06 Feb 1998 20:55:49 GMT

In article <19980206102911.56177@texas.net> you wrote:
> On Fri, Feb 06, 1998 at 10:39:06AM -0500, Rasmus Lerdorf said:

>> >  2322 nobody     1  -5    0 6148K 3268K run   199:12 44.59% httpd
>> >   605 nobody     1  -4    0 5688K 1560K run   734:50 44.10% httpd

>> Ok, the logical thing to do here is to strace or truss -p these suckers
>> and see what the heck they are doing.

> Can you provide your Configuration information (egrep -v ^# Configuration)?
> I'm interested in seeing the modules you've compiled in as I have a pretty
> heavy trafficed web server running on solaris 2.6 and I have yet to see
> this happen.  One think I can think of is perhaps someone is using the
> .htaccess file pointing a password file to /dev/null and that is apache
> going "read-read-read-read-read" in massive loops.  If the process is doing
> nothing but reading, output from an lsof -p would be conclusive on what
> file it is reading (note: lsof is not preinstalled).

Thanks for the hints, I will try lsof and truss when they occur in the next
days. Currently no such processes exists, because the above two I have already
killed and new ones are still not occured. But when they are, I will
investigate to get more information. Anyway, thanks for the hints.

                                       Ralf S. Engelschall
                                       rse@engelschall.com
                                       www.engelschall.com

Mime
View raw message