httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ras...@bellglobal.com
Subject Latest CVS httpd hangs
Date Wed, 28 Jan 1998 20:04:37 GMT
This is the second time in 2 days that I have seen Apache stop answering
requests.  I am running a CVS as of 2 days ago with Dean's chunking patch.
(Solaris 2.5.1, gcc-2.8.0)

A truss on the parent process shows:

poll(0xEFFFDAA0, 0, 1000)                       = 0
time()                                          = 886017547
lseek(15, 0, SEEK_SET)                          = 0
read(15, "\00101\0\0\0\0\00101\0\0".., 1284)    = 1284
waitid(P_ALL, 0, 0xEFFFFA20, WEXITED|WTRAPPED|WNOHANG) = 0
poll(0xEFFFDAA0, 0, 1000)                       = 0
time()                                          = 886017548
lseek(15, 0, SEEK_SET)                          = 0
read(15, "\00101\0\0\0\0\00101\0\0".., 1284)    = 1284
waitid(P_ALL, 0, 0xEFFFFA20, WEXITED|WTRAPPED|WNOHANG) = 0
poll(0xEFFFDAA0, 0, 1000)                       = 0
time()                                          = 886017549
lseek(15, 0, SEEK_SET)                          = 0
read(15, "\00101\0\0\0\0\00101\0\0".., 1284)    = 1284
waitid(P_ALL, 0, 0xEFFFFA20, WEXITED|WTRAPPED|WNOHANG) = 0

etc..  infinitely.

The child processes are all sitting in:

fcntl(14, F_SETLKW, 0x000FA69C) (sleeping...)

Server was compiled with: -DNO_SLACK=1 -DUSE_FCNTL_SERIALIZED_ACCEPT=1

Any clues?  Any other debugging steps I should take?  I can't keeo the
server in this state for much longer.  Need to reset it.

-Rasmus

Mime
View raw message