httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Sutton <p...@eu.c2.net>
Subject Re: confused child
Date Fri, 19 Dec 1997 14:08:42 GMT
On Fri, 12 Dec 1997, Andrew Wilson wrote:
> > So I'd propose we use the following terminology:
> > 
> >   parent   -- the parent process, which looks after other processes
> >               (effect: rename master_main() to parent_main())
> > 
> >   master   -- the "special" thread which looks after the threads
> >               doing the real work (effect: rename worker_main()
> >               to master_main())
> > 
> >   worker   -- a thread which actually does the request processing
> >               (effect: rename child_*_main() to worker_*_main(),
> >               use pworker pool instead of pchild)
> > 
> >   child    -- the name for sub-processes of the parent (that is, the
> >               combination of master and worker threads). This
> >               corresponds to the init_child API phase. 
> > 
> > This renaming should only occur in the NT code (at the moment). It allows
> 
> At the moment.  What do the characters '(' and ')' signify?

Normally they mark a subphrase. If used together (as in '()') they
represent a function name (used above to distinguish functions from
abstract names - such as init_child API phase). 

//pcs



Mime
View raw message