httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Wilson <>
Subject Re: confused child
Date Fri, 12 Dec 1997 18:21:48 GMT
Paul Sutton:
> We use "child" two mean different things in Unix and NT. This can be
> confusing. 

Indeed.  Perhaps it would be best to follow best practice.

> So I'd propose we use the following terminology:
>   parent   -- the parent process, which looks after other processes
>               (effect: rename master_main() to parent_main())
>   master   -- the "special" thread which looks after the threads
>               doing the real work (effect: rename worker_main()
>               to master_main())
>   worker   -- a thread which actually does the request processing
>               (effect: rename child_*_main() to worker_*_main(),
>               use pworker pool instead of pchild)
>   child    -- the name for sub-processes of the parent (that is, the
>               combination of master and worker threads). This
>               corresponds to the init_child API phase. 
> This renaming should only occur in the NT code (at the moment). It allows

At the moment.  What do the characters '(' and ')' signify?

> us to extend Apache in the future without getting ourselves even more
> confused (unless it is only me who is confused by the terminology at the
> moment, of course). 
> //pcs


View raw message