httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Gaudet <dgau...@arctic.org>
Subject Re: [warn] NameVirtualHost 139.25.113.10:39012 has no VirtualHosts
Date Thu, 27 Nov 1997 19:11:58 GMT
That's odd... it doesn't happen for me, can you trace it?  'cause
NameVirtualHost looks like this: 

const char *set_name_virtual_host (cmd_parms *cmd, void *dummy, char *arg)
{
    /* use whatever port the main server has at this point */
    return get_addresses(cmd->pool, arg, &name_vhost_list_tail,
                            cmd->server->port);
}

and get_addresses() doesn't have a bug, all paths to return set the port
or result in an error.  (we'd notice too because <VirtualHost> uses it
too.) 

Dean

On Thu, 27 Nov 1997, Martin Kraemer wrote:

> Recently I always get the warning message
>  [warn] NameVirtualHost 139.25.113.10:39012 has no VirtualHosts
> when I start apache. Is that an uninitialized variable that's leading to
> the :39012 (number varies) message? In the config, I have the following
> VirtualHosts-related items:
> 
>     NameVirtualHost 139.25.113.10
> 
>     <VirtualHost 139.25.113.10:80>
>     ..
>     </VirtualHost>
>     <VirtualHost 139.25.113.10:81>
>     ...
>     </VirtualHost>
>     <VirtualHost _default_:*>
>     ...
>     </VirtualHost>
> 
>   Martin
> -- 
> | S I E M E N S |  <Martin.Kraemer@mch.sni.de>  |      Siemens Nixdorf
> | ------------- |   Voice: +49-89-636-46021     |  Informationssysteme AG
> | N I X D O R F |   FAX:   +49-89-636-44994     |   81730 Munich, Germany
> ~~~~~~~~~~~~~~~~My opinions only, of course; pgp key available on request
> 



Mime
View raw message