httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Slemko <ma...@worldgate.com>
Subject Re: Problem compiling 1.3b2 on Solaris 2.6 w/ gcc 2.7.2.1
Date Thu, 06 Nov 1997 00:38:06 GMT
You can't use an old gcc.  Your header files aren't setup properly; ie.
your compiler isn't installed properly for 2.6.

On Wed, 5 Nov 1997, Philip A. Prindeville wrote:

> I'm compiling apache 1.3b2 on a Solaris 2.6 platform with the
> leftover gcc (2.7.2.1 for Solaris 2.5.1) and I'm getting:
> 
> gcc -c  -I../os/unix -I../main   -DSOLARIS2=260   alloc.c
> In file included from conf.h:66,
>                  from httpd.h:59,
>                  from alloc.c:61:
> /usr/local/lib/gcc-lib/sparc-sun-solaris2.5.1/2.7.2.1/include/sys/param.h:187: warning:
`NBBY' redefined
> /usr/include/sys/select.h:45: warning: this is the location of the previous definition
> In file included from /usr/include/sys/stream.h:26,
>                  from /usr/include/netinet/in.h:38,
>                  from conf.h:726,
>                  from httpd.h:59,
>                  from alloc.c:61:
> /usr/include/sys/model.h:32: #error "No DATAMODEL_NATIVE specified"
> *** Error code 1
> make: Fatal error: Command failed for target `alloc.o'
> Current working directory /usr/local/src/apache_1.3b2/src/main
> *** Error code 1
> make: Fatal error: Command failed for target `subdirs'
> 
> Anyone know what the fix might be?
> 
> Thanks,
> 
> -Philip
> 


Mime
View raw message