httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Tatarinov <tatar...@prairie.NoDak.edu>
Subject Re: Win32 install
Date Tue, 18 Nov 1997 20:30:39 GMT
Ben Laurie wrote:
> 
> available for testing at:
> 
> ftp://www.apache.org/httpd/dist/apache_1.3b3-dev_win32_c.exe
> 
> Cheers,
> 
> Ben.

I was able to use it on my NT Workstation 4.0 but I had some problems.
I wasn't logged in as administrator (is it required?). As a result,
it didn't create a program group (it tried to create a global one 
instead of a personal one). 

Later I wasn't able to start Apache without specifying -f:
apache -f "c:\program files\apache\conf\httpd.conf"

At first it seemed to work but then the screen started scrolling:
fopen: No such file or directory
httpd: could not open document config file c:/program
0: [apache]
1: [-c]
2: [Apache458_55]
3: [-f]
4: [c:/program]
5: [files/apache/conf/httpd.conf]

Apparently, it doesn't like the space in the file name. Adding a -s switch
results in an immediate error message (don't know what -s does)

Finally, I copied httpd.conf to /tmp and was able to start and use Apache in a
standalone mode (not as a service) without problems.

Perhaps, if I started installation as adm I would have all these problems.
Haven't checked it yet, is it really necessary?

I also ran ZeusBench (junker is my pc :) index.html is 
http://www.apache.org/docs/windows.html
 
red:~/web$ ./zb junker /index.html -n 1000 -c 1

---
Server:                 Apache/1.3b3-dev
Doucment Length:        11145
Concurency Level:       1
Time taken for tests:   34.089 seconds
Complete requests:      1000
Failed requests:        0
Bytes transfered:       11387000
HTML transfered:        11145000
Requests per seconds:   29.33
Transfer rate:          334.04 kb/s

Connnection Times (ms)
           min   avg   max
Connect:     1     3    97
Total:      24    32   149


red:~/web$ ./zb junker /index.html -n 1000 -c 3

---
Server:                 Apache/1.3b3-dev
Doucment Length:        11145
Concurency Level:       3
Time taken for tests:   16.787 seconds
Complete requests:      1000
Failed requests:        0
Bytes transfered:       11388460
HTML transfered:        11146218
Requests per seconds:   59.57
Transfer rate:          678.41 kb/s

Connnection Times (ms)
           min   avg   max
Connect:     1     5    53
Total:      31    49   134

Here I looked at the NT task manager monitor and found that only one
apache process (out of 4) was consuming CPU (<40%, hence nw bounded)
Don't know if this is the way it's supposed to work (I mean
one busy process.)

BUT!!!
red:~/web$ ./zb junker /index.html -n 1000 -c 6
Broken Pipe

the same worked fine with the Solaris Apache.

I looked at the error log (btw, can you make it error.log instead of
error_log?). Nothing there.

I guess I should also try the same as adm.

igor

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Igor Tatarinov, graduate student, Computer Science Dept, NDSU
e-mail: tatarino@prairie.nodak.edu   or   itat@acm.org
http://www.cs.ndsu.nodak.edu/~tatarino
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Mime
View raw message