httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Kraemer <Martin.Krae...@mch.sni.de>
Subject Re: [STATUS] 1.3b3-dev Sun Nov 16 10:07:28 EST 1997
Date Sun, 16 Nov 1997 20:49:34 GMT
On Sun, Nov 16, 1997 at 10:17:05AM -0500, Jim Jagielski wrote:
> Very, very close... At present, it looks like the
> only thing is the ``spaces in NT argv'' problem.
> Paul has a suggested patch, which Ben agrees with,
> but Ben points out that a more general solution
> is needed. He will try to work one out. We'll hold
> off on 1.3b3 until Ben decides.
> ==================================================

One thing I noticed this weekend -- didn't try to nail it down yet though --
When the server is started with the "-X" switch, it sometimes locks up
after serving a cpuople of documents. I mean, it still listens on ots port,
but it doesn't read (and answer) any requests any more. And it does this
before its max number of requests is reached.

I observed this behavior both on Linux and on SVR4.
Can anyone else reproduce this?

At the moment of the lockup, I see three httpd's, one is blocked in
read(4,..), when I try to attach strace to the others nothing is
printed -- (not in a sys call?!)

    Martin
-- 
| S I E M E N S |  <Martin.Kraemer@mch.sni.de>  |      Siemens Nixdorf
| ------------- |   Voice: +49-89-636-46021     |  Informationssysteme AG
| N I X D O R F |   FAX:   +49-89-636-44994     |   81730 Munich, Germany
~~~~~~~~~~~~~~~~My opinions only, of course; pgp key available on request

Mime
View raw message